re = /[A-Z a-z 0-9 * - + = _ . # ~ ! ]{1,}/
str = '^@*#(#))#__##
hellow world
dfafa
fdadfa
afafa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end