// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*([*/+-]?=)\s*").unwrap();
let string = "a=\"a\"
b= \"b\"
b +=\"b\"
c = \"c\"";
let substitution = " \\1 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}