#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.)\1{7}"
Local $sString = "pass:" & @CRLF & _
"aaaaaaaa" & @CRLF & _
"bbbbbbbbb" & @CRLF & _
"ccccccccdefg" & @CRLF & _
"11111111" & @CRLF & _
" spaces" & @CRLF & _
"" & @CRLF & _
"fail:" & @CRLF & _
"aaaaaaa" & @CRLF & _
"aaaaaaab" & @CRLF & _
"abababababababab" & @CRLF & _
"1111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")