using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.)\1{7}";
string input = @"pass:
aaaaaaaa
bbbbbbbbb
ccccccccdefg
11111111
spaces
fail:
aaaaaaa
aaaaaaab
abababababababab
1111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}