import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.)\\1{7}";
final String string = "pass:\n"
+ "aaaaaaaa\n"
+ "bbbbbbbbb\n"
+ "ccccccccdefg\n"
+ "11111111\n"
+ " spaces\n\n"
+ "fail:\n"
+ "aaaaaaa\n"
+ "aaaaaaab\n"
+ "abababababababab\n"
+ "1111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}