#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<p>(.*?)<\/p>.*?<span>((?!CHEESE).*?)<\/span>.*?<\/div>"
Local $sString = "<div><p>HELLO1</p>" & @CRLF & _
" <span>SPIDER</span></div>" & @CRLF & _
" <div><p>HELLO2</p>" & @CRLF & _
" <span>CHEESE</span></div>" & @CRLF & _
" <div><p>HELLO3</p>" & @CRLF & _
" <span>BANANA</span></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")