#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm"
Local $sString = "pkg-name.0.15.0-6.x86_64.rpm"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)