using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^abc4(?:.*(?:[^p].{2}|p[^r].{1}|pr[^e])|.{0,2})$";
string input = @"abc4back
abc4backpre
abc4front
abc4frontpre
abc3side
abc3sidepre
xyz4over
xyz4overpre
abc4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}