package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^abc4(?:.*(?:[^p].{2}|p[^r].{1}|pr[^e])|.{0,2})$`)
var str = `abc4back
abc4backpre
abc4front
abc4frontpre
abc3side
abc3sidepre
xyz4over
xyz4overpre
abc4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}