import re
regex = re.compile(r"^abc4(?:.*(?:[^p].{2}|p[^r].{1}|pr[^e])|.{0,2})$", flags=re.MULTILINE)
test_str = ("abc4back\n"
"abc4backpre\n"
"abc4front\n"
"abc4frontpre\n"
"abc3side\n"
"abc3sidepre\n"
"xyz4over\n"
"xyz4overpre\n"
"abc4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")