re = /.+@.+/m
str = '"very.(),:;<>[]\\".VERY.\\"very@\\\\ \\"very\\".unusual"@strange.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end