$re = '/^[^\r\n.]*\K(?<!\S)\KTableA(?!\S)(?=[^\r\n.]*$)/m';
$str = ' Test TableA
TableA AWord
TableA AWord
This.TableA
This. TableA Aword';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);