import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*)(.+?)(,)()";
final String string = "1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,\n\n\n"
+ "FIRST DISPLAY BLOCK REGEX COMMAND\n\n"
+ "[REPLACEALL](\\d*)(.*?)(,)()[WITH] $1 $2\n"
+ "$4";
final String subst = " $1 $2\\n$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}