$re = '/.*?(.{0,10}\bred\b.{0,10}).*/m';
$str = 'Here is a sentence talking about blue. This sentence talks about red.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);