# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\((?<arguments>(([^\(\)']*)|(\([^\(\)']*\))|'(.*?)')*)\)"
test_str = ("Find arguments inside balanced parenthesis.\n"
"Regex idea from Marco https://stackoverflow.com/a/10596403/1898524\n\n\n"
"( arg1, arg2, arg3, (arg4), '(pip' )\n"
"trim(( arg1, arg2, arg2a, arg3, (arg4), '(pip' ))\n"
"SELECT ISNULL(string, left(1,13) )\n\n"
"SELECT ISNULL(string,'x' )\n"
"SELECT ISNULL(string, char(13) )\n"
"SELECT ISNULL(string, char(13) ), ISNULL(string, 'x' )\n\n"
"ISNULL( x )\n"
"ISNULL( char(13))\n\n\n"
"SELECT MID(LTRIM(RTRIM(ISNULL(string, char(13)))),4,8) <-- Does not work on a heavily nested function.\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.