re = /(?<=(?<![^\W\d_])[.,!?()-])(?=[^\W\d_])|(?<=[^\W\d_])(?=[.,!?()-](?![^\W\d_]))/m
str = '!hello 77e! - -world-view- world-view'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result