$re = '/([\d,\.]+)/m';
$str = '9.074,53';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);