#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\<yes or no\. if yes, explain why\>|\<yes\/no\>"
Local $sString = "* Document with a Yes or No if your story impacts any of the following hazard types. If yes, explain why." & @CRLF & _
"** Financial: <yes or no. If yes, explain why>" & @CRLF & _
"** Legal/Regulatory: <yes or no. If yes, explain why>" & @CRLF & _
"** Data Integrity: <yes or no. If yes, explain why>" & @CRLF & _
"** Patient Safety: <yes or no. If yes, explain why>" & @CRLF & _
"** CyberSecurity/Information Security: <yes or no. If yes, explain why>" & @CRLF & _
"" & @CRLF & _
"* Engineer assigned to the project has added a +1 indicating that they discussed the impact this story has with regards to Hazards and agrees with the assessment. " & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes or no. If yes, explain why>" & @CRLF & _
"- *Legal/Regulatory:* <yes or no. If yes, explain why>" & @CRLF & _
"- *Data Integrity:* <yes or no. If yes, explain why>" & @CRLF & _
"- *Patient Safety:* <yes or no. If yes, explain why>" & @CRLF & _
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>" & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes/no>" & @CRLF & _
"- *Legal/Regulatory:* <yes/no>" & @CRLF & _
"- *Data Integrity:* <yes/no>" & @CRLF & _
"- *Patient Safety:* <yes/no>" & @CRLF & _
"- *CyberSecurity/Information Security:* <yes/no>" & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes or no. If yes, explain why>No" & @CRLF & _
"- *Legal/Regulatory:* <yes or no. If yes, explain why> Yes" & @CRLF & _
"- *Data Integrity:* No" & @CRLF & _
"- *Patient Safety:* Yes, this was an issue because of XYZ." & @CRLF & _
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>" & @CRLF & _
"" & @CRLF & _
"- *Financial:* no" & @CRLF & _
"- *Legal/Regulatory:* no" & @CRLF & _
"- *Data Integrity:* no" & @CRLF & _
"- *Patient Safety:* no" & @CRLF & _
"- *CyberSecurity/Information Security:* no" & @CRLF & _
"" & @CRLF & _
"- *Financial:* N" & @CRLF & _
"- *Legal/Regulatory:* N" & @CRLF & _
"- *Data Integrity:* N" & @CRLF & _
"- *Patient Safety:* N" & @CRLF & _
"- *CyberSecurity/Information Security:* N" & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes or no. If yes, explain why>N" & @CRLF & _
"- *Legal/Regulatory:* <yes or no. If yes, explain why> N" & @CRLF & _
"- *Data Integrity:* <yes or no. If yes, explain why>N" & @CRLF & _
"- *Patient Safety:* <yes or no. If yes, explain why>N" & @CRLF & _
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why> N" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes or no. If yes, explain why>" & @CRLF & _
"- *Legal/Regulatory:* <yes or no. If yes, explain why>" & @CRLF & _
"- *Data Integrity:* <yes or no. If yes, explain why>" & @CRLF & _
"- *Patient Safety:* <yes or no. If yes, explain why>" & @CRLF & _
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>" & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes/no>" & @CRLF & _
"- *Legal/Regulatory:* <yes/no>" & @CRLF & _
"- *Data Integrity:* <yes/no>" & @CRLF & _
"- *Patient Safety:* <yes/no>" & @CRLF & _
"- *CyberSecurity/Information Security:* <yes/no>" & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes or no. If yes, explain why>No" & @CRLF & _
"- *Legal/Regulatory:* <yes or no. If yes, explain why> Yes" & @CRLF & _
"- *Data Integrity:* No" & @CRLF & _
"- *Patient Safety:* Yes, this was an issue because of XYZ." & @CRLF & _
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>" & @CRLF & _
"" & @CRLF & _
"- *Financial:* no" & @CRLF & _
"- *Legal/Regulatory:* no" & @CRLF & _
"- *Data Integrity:* no" & @CRLF & _
"- *Patient Safety:* no" & @CRLF & _
"- *CyberSecurity/Information Security:* no" & @CRLF & _
"" & @CRLF & _
"- *Financial:* N" & @CRLF & _
"- *Legal/Regulatory:* N" & @CRLF & _
"- *Data Integrity:* N" & @CRLF & _
"- *Patient Safety:* N" & @CRLF & _
"- *CyberSecurity/Information Security:* N" & @CRLF & _
"" & @CRLF & _
"- *Financial:* <yes or no. If yes, explain why>N" & @CRLF & _
"- *Legal/Regulatory:* <yes or no. If yes, explain why> N" & @CRLF & _
"- *Data Integrity:* <yes or no. If yes, explain why>N" & @CRLF & _
"- *Patient Safety:* <yes or no. If yes, explain why>N" & @CRLF & _
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why> N" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")