// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\+92)?(0092)?(92)?(0)?)(3)([0-9]{9})$").unwrap();
let string = "// Validate it
+923001234567
00923001234567
923001234567
03001234567
3001234567
// Don't Validate
+3001234567
+933001234567
+9230012345672
+923001234567200
030012345672
30012345673";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}