import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+\\s*?(?:lac|crs?|k)\\.";
final String string = "it should not match this65 lac and this 55 lacand this87lacdsdsa\n\n"
+ "should match 76 lac. nd 7 cr. including . It shoudl match 78 lac and 74 crs as well";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}