use strict;
my $str = '[not,35]
[not,5]';
my $regex = qr/\[not,(\d+)\]/p;
my $subst = '-\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";