using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"20(?:09|1\d)";
string input = @"2008
2009
2010
2015
2019
2020";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}