#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^pub\s+(\S+)\s+(\S+)\s+.*\s+.{0,32}(.*)\s+(.*)<(\S+)>"
Local $sString = "pub dsa1024 2018-02-28 [SCA]" & @CRLF & _
" 0019003A003E5A22E2337044D955066111F63B00" & @CRLF & _
"uid [ unknown] John Doe <jogn@doe.name>" & @CRLF & _
"sub elg1024 2018-02-28 [E]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")