using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^pub\s+(\S+)\s+(\S+)\s+.*\s+.{0,32}(.*)\s+(.*)<(\S+)>";
string input = @"pub dsa1024 2018-02-28 [SCA]
0019003A003E5A22E2337044D955066111F63B00
uid [ unknown] John Doe <jogn@doe.name>
sub elg1024 2018-02-28 [E]
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}