package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\((?P<a>[+-]?\d+)?(?P<sign_x>[+-])?(?P<x>[a-zA-Z])(?P<b>[+-]\d+)\)(?:\^(?P<n>\d*))?$`)
var str = `(-1x+1)^3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}