package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`cardType=([^&\s]*)`)
var str = `cardType=A&Return=True
cardType=AbC321
Return=False&cardType=C
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}