re = /cardType=([^&\s]*)/
str = 'cardType=A&Return=True
cardType=AbC321
Return=False&cardType=C
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end