use strict;
my $str = 'The first relative path . or ./some/file/path
The second relative path is .. or ../some/file/path
Where the length of "/some/file/path" is arbitrary';
my $regex = qr/(\.{1,2}(?:\/[[:alnum:]]*)*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}