using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*";
string substitution = @"REPLACEMENT";
string input = @"this
is
my
string";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}