import Foundation
let pattern = #"\B('|")([^\W_]+)\1|\b(?:'|")[^\W_]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ali'den 'cevap'
ali'ten 'cevap'
ali'te 'cevap'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)