import Foundation
let pattern = #"(^|[^"])(Level\s+\d+)(?!["\d])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""Level 3 protected": Level 4 here and "another Level 5""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"$2""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)