import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[(]?(?P<areaCode>\\d{3})[)]?[ .-](?P<phone>\\d{3}[ .-]\\d{4})\\b";
final String string = "YES\n"
+ "(800)-555-1234\n"
+ "212 777.6789\n"
+ "Phone: 800 555-6879.\n\n"
+ "NO\n"
+ "1234567891011\n"
+ "abc def-ghij\n"
+ "800 def.ghij\n"
+ "Phone: 1234567891011";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}