import Foundation
let pattern = #"\b[(]?(?P<areaCode>\d{3})[)]?[ .-](?P<phone>\d{3}[ .-]\d{4})\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
YES
(800)-555-1234
212 777.6789
Phone: 800 555-6879.
NO
1234567891011
abc def-ghij
800 def.ghij
Phone: 1234567891011
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)