use strict;
my $str = 'This is the
first sentence.
This is a really long sentence
and it just keeps going across many
rows there will not necessarily be
punctuation
or consistency in word length
the only difference in ending sentence
is the next row will be blank
here would be the third sentence
as
you see
the blanks between rows of data
help define what a sentence is
this would be sentence 4
i want to pull data
from text file
as such (in sentences)
where sentences are defined with
blank records in between
this would be sentence 5 since blank row above it
and continues but ends because blank row(s) below it';
my $regex = qr/^[ \t]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}