import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[a-z]*([a-z])[^a-z]+(?=\\1))+[a-z]*";
final String string = "elementum magna sodales should match elementum magna, while something like Proin nunc curna, aliquet nec should return Proin nunc curna, aliquet, but an earring should return nothing because n is not the same as e";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}