const regex = /\b(?:[a-z]*([a-z])[^a-z]+(?=\1))+[a-z]*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:[a-z]*([a-z])[^a-z]+(?=\\1))+[a-z]*', 'gi')
const str = `elementum magna sodales should match elementum magna, while something like Proin nunc curna, aliquet nec should return Proin nunc curna, aliquet, but an earring should return nothing because n is not the same as e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}