re = /^(?:(?:(?!^) (?:and|or) )?(?:\b[A-Z]|\B\([A-Z](?: (?:and|or) [A-Z])+\)\B)){2,}$/m
str = 'Valid:
A and B and C and D
(A or B) and C
(A or B or C) and D
(A or B or C or D) and E
A and (B or C) and D
A and (B or C) or (C and D)
A or (B and C)
(A and B) or (C and D)
Invalid:
A and B and C and
(A or B and C
(A or B or C) and D or
(A or B or C or D and E
A and or (B or C) and D
A and (B or (C and D)))
A (B and C)
(A and B) or C and D)
(A and B or C and D)
More Invalid:
A
AB or C
A and
or A and B
A and (A)
(A and B) or'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end