$re = '/ (?:::f{4,6}:)?(?P<host>\S+) -.* "GET \/w00tw00t.*/';
$str = '(e) 89.248.171.2 - - [05/Oct/2014:17:45:54 +0200] "GET /w00tw00t.at.blackhats.romanian.anti-sec:) HTTP/1.1" 403 407 "-" "ZmEu"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);