import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^!NAME:\\s+\"(Slot.*?)\"";
final String string = "!NAME: \"Slot 10 SubSlot 0\"\n"
+ "!NAME: \"Slot 4\"(this works, but the capture string will not always be this small)\n"
+ "!NAME: \"Slot 4 Subslot 12 Internal Subslot 14 External\"\n"
+ "!NAME: \"Slot 75 Internal Slot 12 External\"\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}