const regex = /^!NAME:\s+"(Slot.*?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^!NAME:\\s+"(Slot.*?)"', 'gm')
const str = `!NAME: "Slot 10 SubSlot 0"
!NAME: "Slot 4"(this works, but the capture string will not always be this small)
!NAME: "Slot 4 Subslot 12 Internal Subslot 14 External"
!NAME: "Slot 75 Internal Slot 12 External"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}