#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<=^pow)\(([^()]*|\(([^()]*|\([^()]*\))*\))*\))"
Local $sString = "pow(y,2)" & @CRLF & _
"pow(y,2+2)" & @CRLF & _
"pow(y,2-3)" & @CRLF & _
"pow(y,2.2)" & @CRLF & _
"pow(y,(23)/(2))+23123" & @CRLF & _
"pow(y,pow(2,pow(2,4)))-932" & @CRLF & _
"pow(y,pow(2,1*pow(2,0.5)))+23" & @CRLF & _
"" & @CRLF & _
"//Erro" & @CRLF & _
"pow(y,2)*pow(2,2)" & @CRLF & _
"pow(y,3)-pow(2,2)" & @CRLF & _
"pow(y,4)+pow(2,2)" & @CRLF & _
"pow(y,pow(2,1*pow(2,0.5)))+pow(1,1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")