package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`CPS\d`)
var str = []byte(`CPS, 1, CPM, 17, uSv/hr, 0.09, SLOW`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}