$re = '/\(?\d{2}\)?\s?\d{5}\-?\d{4}/';
$str = '11965453789
(11)965453789
(11) 965453789
(11) 96545-3789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);