re = /\(?\d{2}\)?\s?\d{5}\-?\d{4}/
str = '11965453789
(11)965453789
(11) 965453789
(11) 96545-3789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end