package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`staging\.wpengine\.`)
var str = `https://tgdev.staging.wpengine.com
https://tgdev.wpengine.com
http://localhost
http://127.0.0.1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}