package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)
^
(?= [a-z] .{5,15} $ )
[a-z0-9]* -? [a-z0-9]+
$`)
var str = `PeterParker
Peter-Parker
Peter-P-arker
Peter
PeterParker-
-PeterParker
1PeterParker
Peter Parker
PeterParkerSpiderMan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}