$re = '/([a-z]+|\d+[a-z]*|\([a-z0-9\s()+/*-]+?\))\s*(?:\*?\s*([a-z]+)|\*\s*(\d+[a-z]*)|\*?\s*(\([a-z0-9\s()+/*-]+?\)))\s*(\+|-)\s*(?:\1\s*(?:\*?\s*([a-z]+)|\*\s*(\d+[a-z]*)|\*?\s*(\([a-z0-9\s()+/*-]+?\)))|(?:([a-z]+)|(\d+[a-z]*)|(\([a-z0-9\s()+/*-]+?\)))\s*\*\s*\1)|(?:([a-z]+)|\*\s*(\d+[a-z]*)|\*?\s*(\([a-z0-9\s()+/*-]+?\)))\s*\*\s*([a-z]+|\d+[a-z]*|\([a-z0-9\s()+/*-]+?\))\s*(\+|-)\s*(?:\15\s*(?:\*?\s*([a-z]+)|\*\s*(\d+[a-z]*)|\*?\s*(\([a-z0-9\s()+/*-]+?\)))|(?:([a-z]+)|(\d+[a-z]*)|(\([a-z0-9\s()+/*-]+?\)))\s*\*\s*\15)/i';
$str = 'Can be used to simplify a bit calculs as "2y - z * 2" or (4-z) (x/3 * 4) - (4-z)(1 / xy).';
$subst = "$1$15($2$3$4$12$13$14 $5 $6$7$8$9$10$11$16$17$18$19$20$21$22)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;