import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(e|d|b)-(heme|gome|jome)-([^\\/]+)(?!\\/)";
final String string = "/jome/stat/d-heme-sdfsdf/ertert\n"
+ "/jome/stat/d-heme-sdfsdf\n"
+ "/jome/stat/d-gome-sdfsdf/qeqwe";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}