$re = '/(?<ID>.+?)=(?<Translation>(?:(?!\S+\s*=)[\s\S])+)/m';
$str = 'xxx_error_tx1 = This is xxxx. Johe say:
xxx_error_MapCode = xxx_error_tx1, test this function,Failed,\\
Default, Current,\\
App_Error_tx1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;