use strict;
my $str = 'key_1= "vdsdsalh";
multiline_key = "something
with
many lines";
Key2 = "test with ; symbol";
';
my $regex = qr/(\S+?)\s*=\s*\"([^\t]+)\"\s*(?>;\s*\n)/p;
my $subst = '^[#;].*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";